Strict Standards: Declaration of Walker_Page::start_lvl() should be compatible with Walker::start_lvl($output) in /home/content/80/10679580/html/methegeek/wp-settings.php on line 161

Strict Standards: Declaration of Walker_Page::end_lvl() should be compatible with Walker::end_lvl($output) in /home/content/80/10679580/html/methegeek/wp-settings.php on line 161

Strict Standards: Declaration of Walker_Page::start_el() should be compatible with Walker::start_el($output) in /home/content/80/10679580/html/methegeek/wp-settings.php on line 161

Strict Standards: Declaration of Walker_Page::end_el() should be compatible with Walker::end_el($output) in /home/content/80/10679580/html/methegeek/wp-settings.php on line 161

Strict Standards: Declaration of Walker_PageDropdown::start_el() should be compatible with Walker::start_el($output) in /home/content/80/10679580/html/methegeek/wp-settings.php on line 161

Strict Standards: Declaration of Walker_Category::start_lvl() should be compatible with Walker::start_lvl($output) in /home/content/80/10679580/html/methegeek/wp-settings.php on line 161

Strict Standards: Declaration of Walker_Category::end_lvl() should be compatible with Walker::end_lvl($output) in /home/content/80/10679580/html/methegeek/wp-settings.php on line 161

Strict Standards: Declaration of Walker_Category::start_el() should be compatible with Walker::start_el($output) in /home/content/80/10679580/html/methegeek/wp-settings.php on line 161

Strict Standards: Declaration of Walker_Category::end_el() should be compatible with Walker::end_el($output) in /home/content/80/10679580/html/methegeek/wp-settings.php on line 161

Strict Standards: Declaration of Walker_CategoryDropdown::start_el() should be compatible with Walker::start_el($output) in /home/content/80/10679580/html/methegeek/wp-settings.php on line 161
Me The Geek » Tools
Strict Standards: call_user_func_array() expects parameter 1 to be a valid callback, non-static method runPHP::DetermineAllEvaldPosts() should not be called statically in /home/content/80/10679580/html/methegeek/wp-includes/plugin.php on line 164

Tools


Strict Standards: call_user_func_array() expects parameter 1 to be a valid callback, non-static method runPHP::EvalContent() should not be called statically in /home/content/80/10679580/html/methegeek/wp-includes/plugin.php on line 59

This is a list of the tools I use and recommend. All are supported by all OS, except when noted.

Browsing

This is currently the most important tool for 99% of tech workers. Am I right? And Firefox 2 is better than Internet Explorer 7 for a big number of reasons.


Office Suite

Unless somebody else is paying for it, why would you use an expensive alternative? You can have a great office suite for free:

 Use OpenOffice.org

Communications

Even though there are some things I do not like about Skype, I use it for chatting, VoIP, very sporadic Video Chats, and remote Desktop handling through Unyte.

I make all my long distance calls using Skype. Its rates are unbeatable.


For e-mail, I find myself using gmail most of the time. But having a desktop application still has some benefits. So, on any desktop I use regularly, I install Thunderbird.

Thunderbird

Operating System

This is not a very important piece of software… :-P But I prefer this two Linux distros:

Ubuntu.com openSUSE.org

I just haven’t used the others distros as a PC System much, but I bet Fedora is as good as the other two.

If you want to dig deeper into the Linux distro’s world, take a look at DistroWatch.com.

Share and Enjoy: These icons link to social bookmarking sites where readers can share and discover new web pages.
  • Digg
  • del.icio.us
  • Slashdot
  • Technorati
  • Reddit
  • StumbleUpon

Leave a Reply

© 2020 Me The Geek | Entries (RSS) and Comments (RSS)

Epsilon Web Marketing